Multiple Try/Catch in Control Flow Causing Immediate Failure

  • 35Views
  • Last Post 3 weeks ago
Dominic Santini posted this 21 April 2023

Hi -

Sorry for all the tickets as I learn the system and perform use case testing. 

I have Control Flow packages which should execute integration packages one by one and then execute a SQL task at the end (I tried setting some packages to replicate in parallel but received an error, see other ticket). 

I tried to add Try-Catch processing to each one so the entire Control Flow would finish even if one replication package failed. But if I put more than one Try-Catch into the flow, it will immediately fail with this message:

An item with the same key has already been added.

I don't know what it refers to. I tried naming the Try-Catch elements differently but that does not change anything. 

If I remove the Try-Catch elements and just execute the packages in line, it works fine. And if I have only one Try-Catch it also works fine. 

Please let me know if this is normal behavior, and if there is an alternative way to execute, for example 30 replication packages in a row, execute another task at the end, but not have the entire flow fail because of one bad replication package.

Example package ID: 215082

And run ID: 132241919

Thank you.

Order By: Standard | Newest | Votes
Dominic Santini posted this 21 April 2023

For an example of what I'm trying to solve, see package ID 215056, run ID 132242521. 

Because of a string truncation error in package ID 215075, the entire Control Flow package fails. But for us it is much better if all the other projects sync their data while we investigate the one failing package problem. 


Serhii Muzyka posted this 21 April 2023

Hi Dominic,


Thank you for contacting Skyvia Support.

Please be informed that this issue is being investigated by the development team. Once we have the result, we will reply to you in this topic.


Should you have any other questions, don't hesitate to reach out.


Best regards,


Dominic Santini posted this 3 weeks ago

Hi -

As an experiment, I decided to try this again yesterday, converting two Control Flow packages to have a Try-Catch for each replication package. See package 215079 for example. 

And now they work fine, and the above error no longer occurs. 

Did something change in the platform? 

Anyway I'm glad it seems to work now. 


- Dominic